[Tuto] Installer MPD sur Raspberry Pi (distrib Raspbian)

Re: [Tuto] Installer MPD sur Raspberry Pi (distrib Raspian)

Messagepar Darknico » Jeu 6 Sep 2012 12:02

Tostaki a écrit:Si je résume

Syno + rasp + dac = crac
Syno + dac = crac
Clef USB + rasp + dac = crac
Mac + dac = OK

Le tout sur le même morceau
Le point commun de tout cela, hors du dac, est le secteur

A mon sens, il n'est pas ou peu filtré par les alims du rasp et du syno ce qui inclue des craquements dans le signal

Question : est ce que tous les câbles se chevauchent ou les câbles d'alimentation et de signal sont bien séparés ?

Un test intéressant serait d'isoler les alims et câbles d'alims des cables de signal.
Un second test, si le premier n'est pas concluant, à pas cher, c'est de blinder au papier d'alu les boitiers d'alims et les cables associés. Si cela continue à craquer, essayer sans syno mais avec son alim débranchée

...on mobile...


tu alimentes ton raspberry de quelle maniere?
perso c est un chargeur apple d iphone3gs/nano 5V 1A
cable usb de 15-20cm
Darknico
membre Débutant
membre Débutant
 
Messages: 56
Inscription: Sam 4 Aoû 2012 17:32
Localisation: Lille

Re: [Tuto] Installer MPD sur Raspberry Pi (distrib Raspian)

Messagepar Tony » Jeu 6 Sep 2012 12:04

Tostaki a écrit:Si je résume

Syno + rasp + dac = crac
Syno + dac = crac
Clef USB + rasp + dac = crac
Mac + dac = OK

Le tout sur le même morceau
Le point commun de tout cela, hors du dac, est le secteur

A mon sens, il n'est pas ou peu filtré par les alims du rasp et du syno ce qui inclue des craquements dans le signal

Question : est ce que tous les câbles se chevauchent ou les câbles d'alimentation et de signal sont bien séparés ?

Un test intéressant serait d'isoler les alims et câbles d'alims. Pour tester à pas cher, le papier d'alu est un bon outil. Si cela continue à craquer, essayer sans syno mais avec son alim débranchée

...on mobile...


Non les câbles ne se chevauchent pas, j'ai fait l'essai chez ma soeur et même constat.
Pourtant tu aurais bien raison car mpd n'est pas en cause non plus, je viens d'installer linux sur un vieux PC avec mpd le tout branché sur mon DAC et pas de craquement.
Ma soeur habite le même village que moi. Peut être que le Rasp et sensible et que le secteur n'est pas trés propre par chez nous.
Je vais essayer chez mes parents qui habite un endroit plus civilisé que chez moi.
Dernière édition par Tony le Jeu 6 Sep 2012 16:19, édité 2 fois.
Tony
 

Re: [Tuto] Installer MPD sur Raspberry Pi (distrib Raspian)

Messagepar bz31 » Jeu 6 Sep 2012 12:05

Tostaki a écrit:
Le point commun de tout cela, hors du dac, est le secteur

C'est peut-être aussi linux. C'est-à-dire le Dac Magic Plus a besoin une config spéciale d'alsa. Essayer de voir avec Google s'il y a des gens qui fonctionne avec linux+DacMagicPlus. Si possible, tu peux tester un autre DAC pour voir.

Edit : Tu viens de dire le contraire
Tony a écrit: je viens d'installer linux sur un vieux PC avec mpd le tout branché sur mon DAC et pas de craquement.
Mon hypothèse est fausse.
Ce n'est que mon avis ! (rien de plus)
bz31
membre Expérimenté
membre Expérimenté
 
Messages: 1403
Inscription: Ven 8 Oct 2010 06:43
Localisation: 31

Re: [Tuto] Installer MPD sur Raspberry Pi (distrib Raspian)

Messagepar Tony » Jeu 6 Sep 2012 12:10

Darknico a écrit:
Tostaki a écrit:Si je résume

Syno + rasp + dac = crac
Syno + dac = crac
Clef USB + rasp + dac = crac
Mac + dac = OK

Le tout sur le même morceau
Le point commun de tout cela, hors du dac, est le secteur

A mon sens, il n'est pas ou peu filtré par les alims du rasp et du syno ce qui inclue des craquements dans le signal

Question : est ce que tous les câbles se chevauchent ou les câbles d'alimentation et de signal sont bien séparés ?

Un test intéressant serait d'isoler les alims et câbles d'alims des cables de signal.
Un second test, si le premier n'est pas concluant, à pas cher, c'est de blinder au papier d'alu les boitiers d'alims et les cables associés. Si cela continue à craquer, essayer sans syno mais avec son alim débranchée

...on mobile...


tu alimentes ton raspberry de quelle maniere?
perso c est un chargeur apple d iphone3gs/nano 5V 1A
cable usb de 15-20cm


J'ai essayé avec 2 câbles d'alim différant 5V 1,2A et 5V 2A les 2 vendue officiellement pour le Rasp et même constat.
Tony
 

Re: [Tuto] Installer MPD sur Raspberry Pi (distrib Raspian)

Messagepar Tony » Jeu 6 Sep 2012 12:13

bz31 a écrit:
Tostaki a écrit:
Le point commun de tout cela, hors du dac, est le secteur

C'est peut-être aussi linux. C'est-à-dire le Dac Magic Plus a besoin une config spéciale d'alsa. Essayer de voir avec Google s'il y a des gens qui fonctionne avec linux+DacMagicPlus. Si possible, tu peux tester un autre DAC pour voir.

Edit : Tu viens de dire le contraire
Tony a écrit: je viens d'installer linux sur un vieux PC avec mpd le tout branché sur mon DAC et pas de craquement.
Mon hypothèse est fausse.


Oui effectivement j'utilise la même config de mpd sur le pc linux que sur le Rasp avec le même DAC et la pas de craquement.
Tony
 

Re: [Tuto] Installer MPD sur Raspberry Pi (distrib Raspian)

Messagepar bz31 » Jeu 6 Sep 2012 12:22

Tony a écrit:
bz31 a écrit:
Tostaki a écrit:
Le point commun de tout cela, hors du dac, est le secteur

C'est peut-être aussi linux. C'est-à-dire le Dac Magic Plus a besoin une config spéciale d'alsa. Essayer de voir avec Google s'il y a des gens qui fonctionne avec linux+DacMagicPlus. Si possible, tu peux tester un autre DAC pour voir.

Edit : Tu viens de dire le contraire
Tony a écrit: je viens d'installer linux sur un vieux PC avec mpd le tout branché sur mon DAC et pas de craquement.
Mon hypothèse est fausse.


Oui effectivement j'utilise la même config de mpd sur le pc linux que sur le Rasp avec le même DAC et la pas de craquement.

Je nuance un petit peu. On est pas 100% sûr parce que tu as probablement testé sur linux x86 et linux arm, et aussi les versions de noyaux et d'alsa ne sont pas forcément les mêmes. Le bon fonctionnement d'un software/hardware sur l'un ne signifie pas qu'il va bien fonctionner sur l'autre.
Ce n'est que mon avis ! (rien de plus)
bz31
membre Expérimenté
membre Expérimenté
 
Messages: 1403
Inscription: Ven 8 Oct 2010 06:43
Localisation: 31

Re: [Tuto] Installer MPD sur Raspberry Pi (distrib Raspian)

Messagepar Darknico » Jeu 6 Sep 2012 12:41

le probleme serait donc le syno ou le rasp :/
Darknico
membre Débutant
membre Débutant
 
Messages: 56
Inscription: Sam 4 Aoû 2012 17:32
Localisation: Lille

Re: [Tuto] Installer MPD sur Raspberry Pi (distrib Raspian)

Messagepar Tostaki » Jeu 6 Sep 2012 12:59

essaie de forcer ton Dac Magic Plus sur le mode USB Audio 1.0
La procédure est indiquée ici (page 60) - http://www.cambridgeaudio.com/assets/documents/AP308371-ACADacMagicPlusUsersManual-03French.pdf
Home : Synology DS213+ - Raspberry Pi - Cubox / DAC DIY / Ampli ClassD Audio SDS254 / Enceinte Davis Acoutics Matisse
Ventes : MF M1DAC / Kit DAC DIY TwistedPearAudio
Avatar de l’utilisateur
Tostaki
membre Expérimenté
membre Expérimenté
 
Messages: 1725
Inscription: Lun 11 Juin 2012 19:06
Localisation: Just beyond the screen

Re: [Tuto] Installer MPD sur Raspberry Pi (distrib Raspian)

Messagepar jolemagnifique » Jeu 6 Sep 2012 14:00

On lit ça aussi dans la doc de ce DAC ...

"Un bourdonnement sourd ou un grésillement est perceptible
Des cordons d’alimentation ou une lampe se trouvent à proximité de ce produit. Les entrées analogiques ne sont
pas correctement connectées.
Pour l’USB, essayez de sélectionner la position « Lift » en déplaçant l’interrupteur d’activation/de désactivation de
la masse."
Naim Uniti2+cables HP Esprit Kappa+ Enceintes Thiels CS 1.6 +NAS Synology D211 J
Avatar de l’utilisateur
jolemagnifique
membre Confirmé
membre Confirmé
 
Messages: 919
Inscription: Ven 21 Aoû 2009 12:38

Re: [Tuto] Installer MPD sur Raspberry Pi (distrib Raspian)

Messagepar Tony » Jeu 6 Sep 2012 14:23

Tostaki a écrit:essaie de forcer ton Dac Magic Plus sur le mode USB Audio 1.0
La procédure est indiquée ici (page 60) - http://www.cambridgeaudio.com/assets/documents/AP308371-ACADacMagicPlusUsersManual-03French.pdf


J'avais déjà essayé en USB Audio 1 et il y avait toujours les craquement
Tony
 

Re: [Tuto] Installer MPD sur Raspberry Pi (distrib Raspian)

Messagepar Tony » Jeu 6 Sep 2012 14:26

jolemagnifique a écrit:On lit ça aussi dans la doc de ce DAC ...

"Un bourdonnement sourd ou un grésillement est perceptible
Des cordons d’alimentation ou une lampe se trouvent à proximité de ce produit. Les entrées analogiques ne sont
pas correctement connectées.
Pour l’USB, essayez de sélectionner la position « Lift » en déplaçant l’interrupteur d’activation/de désactivation de
la masse."


J'avais essayé aussi l'interrupteur d'activation/désactivation de la masse et c'était pareil.
Tony
 

Re: [Tuto] Installer MPD sur Raspberry Pi (distrib Raspian)

Messagepar Tony » Jeu 6 Sep 2012 19:38

bz31 a écrit:Je nuance un petit peu. On est pas 100% sûr parce que tu as probablement testé sur linux x86 et linux arm, et aussi les versions de noyaux et d'alsa ne sont pas forcément les mêmes. Le bon fonctionnement d'un software/hardware sur l'un ne signifie pas qu'il va bien fonctionner sur l'autre.


Je pense que tu as raison il doit y avoir un probléme de config propre à la distribution Linux/alsa du rasp qui pose probléme avec mon DAC mais qui fonctionne avec un Linux X86.
On peut oublier le secteur, je viens de réessayer ailleur et même constat (j'ai même essayé avec une alim linéaire que je me suis faite avec des restes de projet DIY)
Tony
 

Re: [Tuto] Installer MPD sur Raspberry Pi (distrib Raspian)

Messagepar bz31 » Jeu 6 Sep 2012 20:35

Tu disais que "Syno+Dac=crac". Ton NAS utilise aussi linux arm comme le rasp.
Il me semble que quelqu'un a eu un problème similaire : https://github.com/raspberrypi/linux/issues/91
Tu peux essayer sa solution.
Ce n'est que mon avis ! (rien de plus)
bz31
membre Expérimenté
membre Expérimenté
 
Messages: 1403
Inscription: Ven 8 Oct 2010 06:43
Localisation: 31

Re: [Tuto] Installer MPD sur Raspberry Pi (distrib Raspian)

Messagepar Tony » Jeu 6 Sep 2012 20:42

bz31 a écrit:Tu disais que "Syno+Dac=crac". Ton NAS utilise aussi linux arm comme le rasp.
Il me semble que quelqu'un a eu un problème similaire : https://github.com/raspberrypi/linux/issues/91
Tu peux essayer sa solution.


Ok merci je vais regarder mais le Syno est d'origine, pas de arm et il y a aussi des craquements avec audiostation.
Le Rasp n'est pas non plus sous arm mais sous raspian
Tony
 

Re: [Tuto] Installer MPD sur Raspberry Pi (distrib Raspian)

Messagepar bz31 » Jeu 6 Sep 2012 20:48

Je n'ai pas bien exprimé. Je voulais dire que ton syno et le rasp a un point commun : ils ont tous les deux des cpu ARM. Leur système est basé sur linux arm. Comme on tourne en rond, on pourra peut-être commencer à vérifier si c'est un problème de linux arm avec ton Dacmagic Plus.
Ce n'est que mon avis ! (rien de plus)
bz31
membre Expérimenté
membre Expérimenté
 
Messages: 1403
Inscription: Ven 8 Oct 2010 06:43
Localisation: 31

PrécédenteSuivante

Retourner vers Musique dématérialisée

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: fdumoncel, Seize et 23 invités